Nvidia fan use issues
Greetings all!

I am running Hashcat 3.0 on Ubuntu 14.04 and on latest Nvidia driver.. having a weird fan issue.. 

I followed the settings in this thread: https://hashcat.net/forum/thread-4569-po...l#pid25931. However I get an error on the fan speed line and it says it cannot change it due to being a read-only attribute. 

Since everything else worked fine, I gave it some hashes to crack and afterawhile both GPUs were pegged around 100% and the temps hit low 80s. Once they hit 82c, I saw the 1070 being throttled. But the fans on both were still reporting only 26-27% in HashCat. Seems suboptimal. :-)

I know this is more of an Nvidia issue than a Hashcat issue but wanted to throw it out there.
The typical reason for that is that you:

1. Did not use XDM, it important for step 2
2. Disable access control to X11, so that hashcat can connect to your X11 session. Read here: https://hashcat.net/wiki/doku.php?id=lin...nvironment
Thanks for your quick reply and sorry for my delay!

I can confirm I installed XDM; I actually used the page you linked as reference in setting up. I again ensured all those packages were installed and everything was configured as you have under the section "configure all the things". I rebooted and same result.

Which setting in your tutorial disables access control on X11?
I think I resolved. Since the follow command gave an error, I dug into it:

nvidia-settings -a GPUCurrentFanSpeed=100

In the release notes for one of their drivers, they note the usage was changed. You can get info on all of the attributes with:

nvidia-settings -q all | grep Fan

After reviewing this, I ran the below command for each GPU. Nvidia-settings took it and now the fans are spinning up/down as needed with HashCat. 

nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan-0]/GPUTargetFanSpeed=75"
That step should not be neccessary with hashcat, it has a build-in enable section for it. Please verify your statement again.
Thanks for your help so far on this. 

So I verified my nvidia-settings command had no effect. When it run the command, it does manually set the fans to the speed I specify - however once I start Hashcat, the fan speeds drop to the previous speeds I had 27-29%. I assume this is because HC takes over fan control. 

I can confirm I followed all the steps on the page you linked. Here is my xdm setup:

export PATH=/bin:/usr/bin:/sbin
export HOME=/root
export DISPLAY=:0
xset -dpms
xset s off
xhost +

Confirmed I am running xdm
[Image: pMU2nNt]

My nvidia driver version is 367.27.

I apologize for my ignorance on this part but you mentioned disabling access control for x11. Which configuration item the link provided takes care of this?
looks like my embedded image got borked. Here is the link: http://imgur.com/pMU2nNt
Nevermind on the access control question - i see it is the link "xhost +". 

I also tried manually running this prior to running hashcat. However the fans on my GPUs still remained at 27%
Just set the fan speed to 100% before running hashcat AND run hashcat with the --gpu-temp-disable switch.

Alternatively, you could also use the --gpu-temp-retain argument and set the (temperature) threshold to a much lower value, e.g. "--gpu-temp-retain 70"

Btw, this definitely are all questions and answers to very, very, very popular posts within the forum. We definitely discussed and answered this questions hundreds of times and also a couple of times very recently (so I recommend that you have a look at the documentation, including but not limited to the --help output, and use the forum search function to find answers to all these frequently asked questions)
If you set it even lower, for example "--gpu-temp-retain 10", then it should instantly set the fan speed to 100%. Please try that and what philsmd said.