amd-gpu-pro update
#11
I think it's a driver misconcept. It should have video group write permission. Anyway, not a hashcat problem!
Reply
#12
(11-14-2016, 08:51 PM)Si2006 Wrote: Why do I have to run hashcat as root!

With a normal user on headless 16.04 i get..

Code:
/hashcat -b -m 2500
hashcat (v3.10-687-gcb6e210) starting in benchmark mode...

/sys/bus/pci/devices/0000:01:00.0/power_dpm_force_performance_level: Permission denied
/sys/bus/pci/devices/0000:07:00.0/power_dpm_force_performance_level: Permission denied
/sys/bus/pci/devices/0000:08:00.0/power_dpm_force_performance_level: Permission denied


OpenCL Platform #1: Advanced Micro Devices, Inc.
================================================
* Device #1: Hawaii, 2047/4026 MB allocatable, 14MCU
* Device #2: Hawaii, 2047/4043 MB allocatable, 14MCU
* Device #3: Hawaii, 2047/4043 MB allocatable, 14MCU
* Device #4: AMD FX(tm)-6300 Six-Core Processor, skipped

Hashtype: WPA/WPA2

Speed.Dev.#1.....:   193.1 kH/s (73.70ms)
Speed.Dev.#2.....:   171.5 kH/s (83.03ms)
Speed.Dev.#3.....:   171.5 kH/s (83.04ms)
Speed.Dev.#*.....:   536.2 kH/s

/sys/bus/pci/devices/0000:01:00.0/power_dpm_force_performance_level: Permission denied
/sys/bus/pci/devices/0000:07:00.0/power_dpm_force_performance_level: Permission denied
/sys/bus/pci/devices/0000:08:00.0/power_dpm_force_performance_level: Permission denied

Hi,

I have the same issue, did you solve it?
Reply
#13
Many thanks for reading, I've given the answer above?

> I think it's a driver misconcept. It should have video group write permission. Anyway, not a hashcat problem!

You're not running as root, that's why you can't enforce power_dpm_force_performance_level to be set. This is activated by benchmark mode btw, in normal runs you don't need it.
Reply
#14
(11-23-2016, 05:08 PM)johnya Wrote: Hi,

I have the same issue, did you solve it?

I changed the ownership of the pwm1 / pwm_enable1 to my current user although you'll have to do this with each system restart.

sudo chown user:user /sys/bus/pci/devices/0000:01:00.0/hwmon/hwmon0/pwm1_enable
Reply
#15
(11-24-2016, 09:07 AM)atom Wrote: You're not running as root, that's why you can't enforce power_dpm_force_performance_level to be set. This is activated by benchmark mode btw, in normal runs you don't need it.

Ok but like SI2006 said it's the same with pwm1_enable in normal runs.

(11-24-2016, 01:41 PM)Si2006 Wrote: I changed the ownership of the pwm1 / pwm_enable1 to my current user although you'll have to do this with each system restart.

sudo chown user:user /sys/bus/pci/devices/0000:01:00.0/hwmon/hwmon0/pwm1_enable

Thank you, I will try it but I don't like to change system function rights...
Reply
#16
You could open an issue on AMD forum to fix the permissions. Good luck with that Wink
Reply
#17
Hi All, aTom,

I have been spending a few nights trying to get this setup working and failed miserably so reaching out for help:
From this post it sounds like I have missed something as opencl is not seeing my GPU.
Here is what I have done:

[Gone to: https://hashcat.net/wiki/doku.php?id=linux_server_howto
Given the note from Atom earlier in this thread I downloaded v16: ubuntu-16.04.1-server-amd64.iso
Installed it with solely the OpenSSH ticked (removed system utilities which is now ticked by default)
All other settings were left as their default]

[After first boot and login:]
sudo apt-get install aptitude
sudo apt-get update && sudo apt-get upgrade
sync && sudo reboot

[Then on next login:]
sudo dpkg --remove-architecture i386
sudo aptitude update && sudo aptitude -y full-upgrade  
sync && sudo reboot

[Then on next login:
happy to see:
0 packages can be updated.
0 updates are security updates.]
sudo aptitude install build-essential dkms xserver-xorg xserver-xorg-core \
xserver-xorg-input-evdev xserver-xorg-video-dummy x11-xserver-utils fglrx xdm
sync && sudo reboot

[after the login I have
Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-53-generic x86_64)
0 packages can be updated.
0 updates are security updates.]

[I do a ] xz -d amdgpu-pro-16.40-348864.tar.xz  
followed by a tar xvf amdgpu-pro-16.40-348864.tar
[which creates a amdgpu-pro-16.40-348864 folder

[At that point I updated the amd-pro install file to remove the 32 bit libraries and there is apparently an issue in the code too with]  
echo ${dir}${etc}${sourceparts}/amdgpu-pro.list
[to be replaced with ...]
echo ${dir}${etc}/${sourceparts}/amdgpu-pro.list

[then I run]  ./amdgpu-pro-install    [No output errors shown]

[Next I run] /opt/amdgpu-pro/bin/clinfo    [The output shows my CPU but nothing with regards my GPU so this does not look healthy]


[Anyway I keep following the original howto so I then do the following:]

 git clone https://github.com/hashcat/hashcat.git
 cd hashcat
 git submodule init
 git submodule update
 make
 sudo make install

[I run] hashcat -I [and no surprise I still get the 1 device which is the following:

 Device ID #1
    Type           : CPU

Can anybody point out what I did wrong or not do?]
Reply
#18
Hi NoInstall,

Its seem you have installed "fglrx" package. This is outdated AMD driver.

(12-10-2016, 11:28 PM)NoInstall Wrote: sudo aptitude install build-essential dkms xserver-xorg xserver-xorg-core \
xserver-xorg-input-evdev xserver-xorg-video-dummy x11-xserver-utils fglrx xdm

You should completely uninstall fglrx (https://hashcat.net/wiki/doku.php?id=fre...hould_i_do) and reinstall amd-gpu pro.
Reply
#19
thanks Johnya

So I rebuilt my box completely from scratch with your pointers and my GPU is still not found.
Given my AMD based GPU the install is not straightforward so this is a list of updated steps I follow...


[Gone to: https://hashcat.net/wiki/doku.php?id=linux_server_howto
Given the note from Atom earlier in this thread I downloaded v16: ubuntu-16.04.1-server-amd64.iso
Installed it with solely the OpenSSH ticked (removed system utilities which is now ticked by default)
All other settings were left as their default]

[After first boot and login:]
sudo apt-get install aptitude
sudo apt-get update && sudo apt-get upgrade
sync && sudo reboot

[Then on next login:]
sudo dpkg --remove-architecture i386
sudo aptitude update && sudo aptitude -y full-upgrade  
sync && sudo reboot


[I follow the link provided by johnya, and I issue]  amdconfig --uninstall=force
[I get -bash: amdconfig: command not found      so this suggests the drivers did not install]

sudo dpkg -S libOpenCL  [gives me ... dpkg-query: no path found matching pattern *libOpenCL*  ... so this should be good not to find any trace of the lib]

[Anyway I still issue]  sudo find / -name libOpenCL\* -print0 | xargs -0 rm -rf    
[I reboot the box]

[then I issue]
apt-get install ocl-icd-libopencl1 opencl-headers clinfo

[then I do a ] xz -d amdgpu-pro-16.40-348864.tar.xz  
followed by a tar xvf amdgpu-pro-16.40-348864.tar
[which creates a amdgpu-pro-16.40-348864 folder

[At that point I updated the amd-pro install file to remove the 32 bit libraries]
[Also I update the following code too which is missing forward slash]  
echo ${dir}${etc}${sourceparts}/amdgpu-pro.list
[to be replaced with ...]
echo ${dir}${etc}/${sourceparts}/amdgpu-pro.list

[then I run]  ./amdgpu-pro-install    [No output errors shown.  Note that I run this as Atom suggested this version 16.40 should work with AMD based GPU earlier in the thread]

sudo reboot

[Next I run] whereis clinfo
clinfo: /usr/bin/clinfo /opt/amdgpu-pro/bin/clinfo /usr/share/man/man1/clinfo.1.gz

[both ] clinfo -I [give me:  The output shows my CPU but nothing with regards my GPU Sad ]

[Anyway I keep following the original howto so I then do the following:]
rm -rf ~/.hashcat/kernels

[then]
 git clone https://github.com/hashcat/hashcat.git
 cd hashcat
 git submodule init
 git submodule update
 make
 sudo make install

[I run] hashcat -I
[and same I still get the 1 device which is the following:

 Device ID #1
    Type           : CPU

Can anybody help?
thanks
]
Reply
#20
What is your GPU? Is it compatible with amd-gpu pro drivers? You can check it here : support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver–Release-Notes.aspx
Reply