Hashcat not starting with --restore
Hii there,

it has been a while since I've used Hashcat, but I tried to crack some WPA2 keys I captured.
I ran it overnight, and it worked fine, but then I had to use the machine (it's my gaming PC lol), so I pressed [q]uit
Then, tonight I wanted to start it again and all my progress was lost.

I read the help provided with the command below and came across the "--restore" parameter:
hashcat64.exe --help

So, I added this to my bat file, and now it refuses to work.
This is my batfile:
Hashcat64.exe -d 1,2 -w 3 -m 2500 -a3 crack.hccapx ?u?u?u?u?u?u?u?u --restore

and this is the output it gives me:
Z:\Hashcat\Hashcat>Hashcat64.exe -d 1,2 -w 3 -m 2500 -a3 crack.hccapx ?u?u?u?u?u
?u?u?u --session=wpa2 --restore
Usage: Hashcat64.exe [options]... hash|hashfile|hccapxfile [dictionary|mask|directory]...

Try --help for more help.

Press any key to continue . . .

Does anybody know what I'm doing wrong?

Hmm... I don't really see exactly how it would help me yet, but I think you are pointing me to this sentence?:
Further parameters and switches are currently not allowed

EDIT: got it to work by making another file containing the "--restore", and removing it from the main file.
thanks Big Grin