Outputting Rules using stdout
I have tried to use the example in this thread...

At first this worked using the command below and a custom rule ..

hashcat-5.1.0>hashcat64.exe -r rules/vb.rule --stdout found.txt | sort.exe -u > magled.txt

But when I stop it using ctrl C and try to run it again I keep getting this error...

^Csort.exe: open failed: \s554.: No such file or directory

Both sort and the text file are in the hashcat folder and the vb.rule is in hashcats rules folder
can anyone shed any light on this problem for me.
I would say that you should just try to type the whole line again (no copy-paste or scrollback).

There is probably some control character and/or ^C directly within your command line and therefore it doesn't work.

if you have a pipe you can always try both parts independently. e.g. to see if the sort command works and independently see if the left command (hashcat64.exe) works on their own.

for instance with sort you could just test it with :
type example.dict | sort.exe -u

sort.exe -u example.dict

just to see if the sort command works if used alone (without the pipe and without hashcat involved)

I would say this is not really a problem with hashcat, but just a command line "problem", completely unrelated to hashcat.
Hi m8
thanks for the feedback, I have tried both of the examples that you gave
and all seems to work fine.

I will take a closer look at my command.

Just typed as you said and there seems to be a problem opening the file after the sort.exe -u
will keep working at it till I find a solution.

thanks again

Think I may have found the problem - created by myself

In my quest to keep the size of the resultant text file to a minimum...
pressing Ctrl+C terminated the programme and there for was unable to write
to the new file.

Will just have to work with smaller text files in future.