Hashcat 3 (from git) and OSX
First, I couldn't download the binaries from main site, so I downloaded from git and complied it (no errors) 

It seems like it really runs very slow, number of hashes is right, hash type is right. Not sure if it's a bug or the real deal. Will also like to know if there's an option to switch to CPU to check if it's faster.

Using OSX 10.11.5, MacMini 2014 stock (Intel Iris 1536 MB) 

After running it I get this information 
Session.Name...: hashcat
Status.........: Running
Input.Mode.....: File (/Users----/Downloads/rockyou.txt)
Hash.Target....: File (/Users/----/Downloads/hashes.txt)
Hash.Type......: bcrypt, Blowfish(OpenBSD)
Time.Started...: Mon Jul 11 08:50:11 2016 (2 hours, 51 mins)
Time.Estimated.: > 10 Years
Speed.Dev.#2...:       74 H/s (16.45ms)
Recovered......: 0/2180 (0.00%) Digests, 0/2180 (0.00%) Salts
Recovered/Time.: CUR:0,0,N/A AVG:0.00,0.00,0.00 (Min,Hour,Day)
Progress.......: 795840/31268387460 (0.00%)
Rejected.......: 0/795840 (0.00%)
Restore.Point..: 320/14343297 (0.00%)
You're attacking bcrypt, what do you expect?
I don't really recall it being that slow last time, but never mind that...
Is it possible to switch between GPU and CPU usage? 

From what I understand my hashcat is now using the GPU, perhaps it will be faster with the CPU? or both? 

Quote:OpenCL Platform #1: Apple               
- Device #1: Intel(R) Core(TM) i5-4278U CPU @ 2.60GHz, skipped
- Device #2: Iris, 384/1536 MB allocatable, 40MCU
From the --help output:
-D, --opencl-device-types

and yes both just single device types e.g. -D 1 and also multiple device types e.g. -D 1,2 is possible
Wait, bcrypt have different settings of iterations. Maybe you're trying to crack a bcrypt with a higher iteration than the hash you tried to crack before.
Used the last hashes last time, had less and i ran it in VM. Too bad I can't use CPU only /cry
Why do you say you (quote : ) "can't use CPU only" ? This is exactly what -D 1 does (with support from your CPU OpenCL driver).
BTW: it's also possible to use hashcat-legacy - formerly called "cpu hashcat" or "hashcat cpu" -- for bcrypt (but of course it's not recommended since it was replaced by hashcat 3.00)

When I use -D 1
It's a known bug in Apples OpenCL runtime. We can't do anything on it