4.01 resume after pause don't activate video card cooler to useful speed.
#1
And Hello again, developers!
I ran into one small, not very important, but a bug.
If I put a pause during the job, and then, after some time I resume the job, the cooler of the video card starts to go very slowly to the working speed. The video card overheats and the job stops. If after this job is started again, the brute force continues without problems.
Shortened log attached.
Is it a problem with my hardware or the program?

Code:
Session..........: my4
Status...........: Running
Hash.Type........: descrypt, DES (Unix), Traditional DES
Hash.Target......: dc/MTCjpopPk.
Time.Started.....: Thu Nov 30 22:20:04 2017 (46 secs)
Time.Estimated...: Mon Dec 04 07:58:06 2017 (3 days, 9 hours)
Guess.Mask.......: ?1?2?2?2?2?2?2?3 [8]
Guess.Charset....: -1 ?l?d?u, -2 ?l?d, -3 ?l?d*!$@_, -4 Undefined
Guess.Queue......: 8/8 (100.00%)
Speed.Dev.#1.....: 12734.2 kH/s (34.56ms)
Speed.Dev.#2.....:  4306.0 kH/s (120.93ms)
Speed.Dev.#*.....: 17040.3 kH/s
Recovered........: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.........: 526322259968/5533380698112 (9.51%)
Rejected.........: 0/526322259968 (0.00%)
Restore.Point....: 6547584/68864256 (9.51%)
Candidates.#1....: 1za84sz1 -> ztasgbpi
Candidates.#2....: 54p53lz1 -> Yt3zrrwi
HWMon.Dev.#1.....: Temp: 77c Fan: 79%
HWMon.Dev.#2.....: N/A
[s]tatus [p]ause [b]ypass [c]heckpoint [q]uit =>
Paused

[s]tatus [p]ause [b]ypass [c]heckpoint [q]uit =>
Resumed

Session..........: my4
Status...........: Running
Hash.Type........: descrypt, DES (Unix), Traditional DES
Hash.Target......: dc/MTCjpopPk.
Time.Started.....: Thu Nov 30 22:20:04 2017 (57 mins, 11 secs)
Time.Estimated...: Thu Mar 24 05:34:58 2022 (4 years, 113 days)
Guess.Mask.......: ?1?2?2?2?2?2?2?3 [8]
Guess.Charset....: -1 ?l?d?u, -2 ?l?d, -3 ?l?d*!$@_, -4 Undefined
Guess.Queue......: 8/8 (100.00%)
Speed.Dev.#1.....:    17207 H/s (34.42ms)
Speed.Dev.#2.....:    19604 H/s (118.45ms)
Speed.Dev.#*.....:    36811 H/s
Recovered........: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.........: 526434805760/5533380698112 (9.51%)
Rejected.........: 0/526434805760 (0.00%)
Restore.Point....: 6549440/68864256 (9.51%)
Candidates.#1....: Z2mw1mff -> o4sk4a52
Candidates.#2....: S8tofmff -> coema2ie
HWMon.Dev.#1.....: Temp: 54c Fan: 33%
HWMon.Dev.#2.....: N/A
[s]tatus [p]ause [b]ypass [c]heckpoint [q]uit =>

.....

Session..........: my4
Time.Started.....: Thu Nov 30 22:20:04 2017 (58 mins, 25 secs)
HWMon.Dev.#1.....: Temp: 90c Fan: 33%
HWMon.Dev.#2.....: N/A

Temperature limit on GPU #1 reached, aborting...

Session..........: my4
Status...........: Aborted
Hash.Type........: descrypt, DES (Unix), Traditional DES
Hash.Target......: dc/MTCjpopPk.
Time.Started.....: Thu Nov 30 22:20:04 2017 (58 mins, 27 secs)
Time.Estimated...: Mon Dec 04 06:41:35 2017 (3 days, 7 hours)
Guess.Mask.......: ?1?2?2?2?2?2?2?3 [8]
Guess.Charset....: -1 ?l?d?u, -2 ?l?d, -3 ?l?d*!$@_, -4 Undefined
Guess.Queue......: 8/8 (100.00%)
Speed.Dev.#1.....: 12863.8 kH/s (34.35ms)
Speed.Dev.#2.....:  4651.5 kH/s (111.48ms)
Speed.Dev.#*.....: 17515.3 kH/s
Recovered........: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.........: 527766978560/5533380698112 (9.54%)
Rejected.........: 0/527766978560 (0.00%)
Restore.Point....: 6565184/68864256 (9.53%)
Candidates.#1....: rvg5o9z1 -> Phknywz1
Candidates.#2....: g8q3f5xi -> Xqx65fvo
HWMon.Dev.#1.....: Temp: 91c Fan: 33%
HWMon.Dev.#2.....: N/A


Attached Files
.txt   my4.txt (Size: 7.24 KB / Downloads: 1)
Reply
#2
hashcat doesn't control GPU fan speed which is basically what your issue boils down to. That's controlled by the GPU's firmware but can be overridden with fan speed control software such as MSI Afterburner.

But it's not hashcat's fault.
Reply
#3
I also thought, but why does it only appear in hashcat? And only after pause?
Reply
#4
I've removed fan speed control in latest beta, you can find it here: https://hashcat.net/beta/
Reply
#5
Hello, Atom!
I think the temperature control option is very necessary and suitable. You could make several keys at startup and the default choice is whether there is an option or not, the ability to set the minimum fan speed and the maximum in percent. And it seems to me that after a pause, the fan speed control function is somehow not working. I think you can do it right.
Now I'm testing your latest build. It became quieter - it's a fact.
Before: Temp: 79-80c Fan: 80%.
Now: Temp: 83c Fan: 61%
Best regards!
Reply
#6
I'm testing now. Everything works adequately.
In the past build on one of the computers had such an effect that the cooler worked with fast waves. But since it was more noisy, it turned out that it worked less loudly, then much loudly.

Nevertheless, the management of the cooler in each of the devices involved is a necessary option.
For example:
-te d01 v (-te - temperature option, 01 - device, v - variable cooler work managing by hashcat)
-te d02 mi60 ma80 (-te - temperature option, 02 - device, mi60 - fan minimum 60%, ma80 - fan maximum 80%)
-te d03 d (-te - temperature option, 03 - device, d - variable cooler work managing by hashcat disabled. Used system settings)
Reply
#7
Please use an external program for fan speed control
Reply
#8
ok) thank you) Will keep both versions.
Reply