1080ti slow speed performance WPA/WPA2
#1
Hi, all.
I have slow speed performance WPA/WPA2 with a wordlist in hashcat.I’m using 2 GTX 1080ti FE and executed hashcat for crack WPA/WPA2 with a Wordlist.

I’m using 2 GTX 1080 ti FE and executed hashcat for crack WPA/WPA2 with a wordlist.

For example, 8 digits wordlist test speed:hashcat64.exe -a 0 --session=2018-02-02 -m 2500 -w 3 --force -p : --status --status-timer=10 --gpu-temp-disable -o "C:\Hashcat\HashcatGUI\Xiaomi_found2500.txt" --outfile-format=3 "C:\Xiaomi.hccap" "C:\Hashcat\dic\8x.dic"

Status.........: Exhausted
Input.Mode.....: File (C:\Hashcat\dic\8x.dic)
Hash.Target....: Xiaomi (34:ce:00:5e:dc:00 <-> 10:a4:be:02:cf:ea)
Hash.Type......: WPA/WPA2
Speed.Dev.#1...:   461.1 kH/s (84.91ms)
Speed.Dev.#2...:   466.4 kH/s (85.05ms)
Speed.Dev.#*...:   927.4 kH/s

When is used the brute-force mask for crack WPA/WPA2, i have a correct speed:hashcat64.exe -a 3 - -w 3 --force -p : --status --status-timer=10 --gpu-temp-disable -o "C:\Hashcat\HashcatGUI\ALHN-EF53_found2500.txt" --outfile-format=3 "C:\ALHN-EF53.hccap" ?d?d?d?d?d?d?d?d?d?d

Status.........: Running
Input.Mode.....: Mask (?d?d?d?d?d?d?d?d?d?d) [10]
Hash.Target....: ALHN-EF53 (54:a6:19:ec:72:60 <-> 2c:f0:a2:51:6a:48)
Hash.Type......: WPA/WPA2
Speed.Dev.#1...:   512.2 kH/s (100.36ms)
Speed.Dev.#2...:   526.6 kH/s (100.06ms)
Speed.Dev.#*...:  1038.7 kH/s

I'm testing hashcat 3.10 -3.40 , and the speed same in all version:2x 1080ti wordlist speed: 927.4 - 960 kH/s, and 2x 1080ti mask speed:1039 kH/sIn hashcat 4.0.1. - very slow speed: 550 kH/s at 2x GTX 1080 ti FE.

Who knows why such a difference in speed?How to make the speed higher when cracking WPA/WPA2 at Wordlist?

Sorry for my english...
-----
My system:
Windows 7 (64) and Windows 10 (64)
GPU 2x 1080ti FE
GPU driver version: 390/65
CPU AMD fx-8350
Corsair HX1200i 1200 Watt
Reply
#2
Why are you using --force? Try with -w4
Reply
#3
The main difference between older version and 3.5+ is that we're doing the nonce error corrections, as described in detail here: https://hashcat.net/forum/thread-6361.html

You can turn it off in v4.x, just append --nonce-error-corrections=0 to the commandline.
Reply
#4
(02-02-2018, 04:36 PM)undeath Wrote: Why are you using --force? Try with -w4
I try tested hashcat wordlist WPA attack without "--force" and with "-w4", and i have the same slow speed performance (((.
Reply
#5
(02-02-2018, 04:43 PM)atom Wrote: The main difference between older version and 3.5+ is that we're doing the nonce error corrections, as described in detail here: https://hashcat.net/forum/thread-6361.html

You can turn it off in v4.x, just append --nonce-error-corrections=0 to the commandline.
Tested wpa wordlist attack hashcat 4.0.1.:
hashcat64.exe -a 0 -m 2500 -w 4 -p : --status --status-timer=1 --nonce-error-corrections=0 --gpu-temp-disable -o "C:\8020_1517045065_found2500.txt" --outfile-format=3 "C:\8020_1517045065.hccapx" "C:\8x.dic"

Hash.Type........: WPA/WPA2
Speed.Dev.#1.....:   396.0 kH/s (374.00ms)
Speed.Dev.#2.....:   406.7 kH/s (364.62ms)
Speed.Dev.#*.....:   802.7 kH/s

I think it's to slow speed.
Reply
#6
Are these 1080s or 1080Tis? Cause if they are 1080s, that seems to be pretty normal. Your title says Ti, but your first post multiple times just says 1080 FE.
Reply
#7
(02-02-2018, 07:39 PM)tacohashcat Wrote: Are these 1080s or 1080Tis? Cause if they are 1080s, that seems to be pretty normal. Your title says Ti, but your first post multiple times just says 1080 FE.
2x Nvidia  GTX 1080Ti FE
Reply
#8
Please post full output of hashcat -b -m 2500 and hashcat -I
Reply
#9
(02-02-2018, 09:38 PM)atom Wrote: Please post full output of hashcat -b -m 2500 and hashcat -I

hashcat64.exe -b -m 2500

Code:
hashcat (v4.0.1) starting in benchmark mode...

Benchmarking uses hand-optimized kernel code by default.
You can use it in your cracking session by setting the -O option.
Note: Using optimized kernel code limits the maximum supported password length.
To disable the optimized kernel code in benchmark mode, use the -w option.

OpenCL Platform #1: NVIDIA Corporation
======================================
* Device #1: GeForce GTX 1080 Ti, 2816/11264 MB allocatable, 28MCU
* Device #2: GeForce GTX 1080 Ti, 2816/11264 MB allocatable, 28MCU

Benchmark relevant options:
===========================
* --optimized-kernel-enable

Hashmode: 2500 - WPA/WPA2

Speed.Dev.#1.....:   523.7 kH/s (53.92ms)
Speed.Dev.#2.....:   545.4 kH/s (51.50ms)
Speed.Dev.#*.....:  1069.1 kH/s

Started: Sat Feb 03 09:36:34 2018
Stopped: Sat Feb 03 09:36:59 2018

hashcat64.exe -I

Code:
hashcat (v4.0.1) starting...

OpenCL Info:

Platform ID #1
  Vendor  : NVIDIA Corporation
  Name    : NVIDIA CUDA
  Version : OpenCL 1.2 CUDA 9.1.84

  Device ID #1
    Type           : GPU
    Vendor ID      : 32
    Vendor         : NVIDIA Corporation
    Name           : GeForce GTX 1080 Ti
    Version        : OpenCL 1.2 CUDA
    Processor(s)   : 28
    Clock          : 1582
    Memory         : 2816/11264 MB allocatable
    OpenCL Version : OpenCL C 1.2
    Driver Version : 390.65

  Device ID #2
    Type           : GPU
    Vendor ID      : 32
    Vendor         : NVIDIA Corporation
    Name           : GeForce GTX 1080 Ti
    Version        : OpenCL 1.2 CUDA
    Processor(s)   : 28
    Clock          : 1582
    Memory         : 2816/11264 MB allocatable
    OpenCL Version : OpenCL C 1.2
    Driver Version : 390.65
Reply
#10
We did some more changes to the code. Please download latest RC (RC6) from https://hashcat.net/beta/ or compiler from github master and retry.
Reply