Hashcat sees my GPU but not my CPU
I finally have hashcat working unfortunatly it's on Windows 10 Pro but keep getting Device 1 ATTENTION Opencl Kernel self-test failed. Then it says my device driver is probably broken I followed every tutorial I can find I have installed several drivers multiple times. Is there any way to get it to work? I'm fairly happy with the results now my hs went up by 70,000 but I obviously want it as high as I can get it. My CPU is an Intel i5 the GPU is an AMD rx 560 lp. Any help would be fantastic.
use the latest beta version from https://hashcat.net/beta/ to fix the error with your gpu,
Sneaky bastard?
[Image: avatar_85.jpg?dateline=1337188913]
I retried the Crimson driver as per the Hashcat instructions it stopped running. It now shows three devices three devices skips 1 and 3 then gets stuck on initializing. Is there any driver or opencl it will accept?
run this:

or (filtered):

clinfo | grep "Platform Name"

if some very basic third party tools like "clinfo" do not recognize your OpenCL installation, also hashcat can't do anything with your setup.
First I didn't know you could do that thank you very much. I usually use Linux not Windows so I know very little about windows thank you again. Now this, it shows the opencl. Actually it shows two one for the GPU, and another for the CPU. I saw in a reply about trying the beta version since it is showing the opencl should I even bother, or is there a chance it will work ? Here's what I was getting 5765 H/s on cpu only now I have to put in  --self-test-disabled and get 79344 is it going to make a big difference ? I'm starting to think just enter the extra command and just run it, but even with the command Hashcat says it's running slower than expected if it is expecting only another 5000 then I'm at the point that I don't care. This seems to be a common problem with no solution, I have been through four operating systems trying to get it to work and it is the same. If it's only a matter of a few thousand please let me know and I'll just enter the extra command and ignore the message Hashcat keeps giving me. Thank you again for your help.
If the self test is failing hashcat will be unable to crack hashes. This has nothing to do with speed.
I didn't know that. I tried beta same deal will only run if I disable self test. Do you have any idea how to fix this ? I bought the GPU for Hashcat I don't game on my PC. It runs perfectly with everything except Hashcat. I have tried everything even that how do I know if I have the right driver again since AMD sent me a tool to remove all of the driver. That one worked better but it was the same result it messed up my monitor and Hashcat wouldn't run even with self test disabled. I reported the problem on Git Hub but no answer. All I can find is people asking how to fix it and getting the same responses which don't work. AMD says it's a Hashcat problem, Msi says it's a Hashcat problem, Hashcat says it's a driver problem. If the GPU works on everything but Hashcat it has to be a Hashcat problem. I don't know I might be wrong but I'm four OS's into this and the best two suggestion I've got was grep and you saying try beta. This is killing me I thought it would atleast crack the password with the test disabled.
If you bought the card specifically for hashcat the question is why you chose AMD at all. Their OpenCL runtime is known to be garbage and their hardware is poorly suited for hashcat's purposes, compared to Nvidia cards. But anyway…

First off, if hashcat fails to detect your card that's an error in the OpenCL runtime (the driver you are using) or in very rare cases on the OS level (no/bad OpenCL loader). Hashcat has absolutely no influence on that, it's all third-party libraries. clinfo (as recommended by philsmd) can be used to verify your OpenCL libraries are correctly installed.

If hashcat detects your device but throws errors that's almost always an error in the OpenCL runtime you are using. This is proven by occasional driver updates that suddenly make things work or break previously working things. This happens much more frequently with AMD drivers, but Nvidia drivers do have similar issues. Hashcat developers do add workarounds for known bugs in the vendors' implementations but not all of those bugs are known and of course they only have limited time.

All that said, usually hashcat should be running fine at least on linux. Hashcat is being developed and tested on Ubuntu (with rocm in case of AMD). Don't install the official AMD drivers on linux. On Windows the latest AMD driver on a freshly installed system has so far worked for almost everyone else. You still have can trouble with failing self-tests though, that sometimes are worked around in the beta version.