V59 is up
#1
OK, here it is..

I have added support for the MOSIX/VCL aka virtual opencl cluster network.

You dont need to have MOSIX installed at all - VCL 1.15 is enough. Have Fun. BTW: I tested it successfully with 22 GPUS Smile

Here some nice benchmark: https://docs.google.com/a/plain-text.inf...hRUE#gid=0

More important is that there should be no issues left on AMD. That means 2711 and 2811, too. Double verify you remove all *.kernel files in case you overwrite the directory.

NV still has issues left.
#2
Here's my bug report for v56, the other topic got closed too quickly:

System: Windows 7 64 bit, Driver 306.02 GTX470, oclhashcat-plus beta 56

- Bruteforce does not work for the following algos: 0, 10, 11, 20, 21, 30, 40, 100, 101, 110, 111, 112, 120, 121, 122, 140, 141, 300, 900, 1000, 1100, 1400, 1400, 1410, 1420, 1500, 1700, 1710, 1720, 1722, 2400, 2600, 2611, 2711, 2811, 3000, 3100
- Minor variation of the above bruteforce problem, only length 2 works: 130, 131, 132
- For -m 130 sha1(unicode($pass).$salt), beside the general -a 3 problem, -a 1 and -a 7 does not work.
- For -m 131 MSSQL(2000), beside the general -a 3 problem, -a 1 does not work except for length 4, -a 7 does not work for all length.
- For -m 132 MSSQL(2005), -a 1 and -a 7 does not work.
- For -m 1710 sha512($pass.$salt), only -a 0 works.
- For -m 2711 vBulletin > v3.8.5, only -a 0 works.
- For -m 2811 IPB2+, MyBB1.2+, only -a 0 works.

Will try the v59 on AMD now.
#3
b60 up:

fixed:

Quote:- Bruteforce does not work for the following algos: 0, 10, 11, 20, 21, 30, 40, 100, 101, 110, 111, 112, 120, 121, 122, 140, 141, 300, 900, 1000, 1100, 1400, 1400, 1410, 1420, 1500, 1700, 1710, 1720, 1722, 2400, 2600, 2611, 2711, 2811, 3000, 3100
- For -m 130 sha1(unicode($pass).$salt), beside the general -a 3 problem, -a 1 and -a 7 does not work.
- For -m 131 MSSQL(2000), beside the general -a 3 problem, -a 1 does not work except for length 4, -a 7 does not work for all length.
- For -m 132 MSSQL(2005), -a 1 and -a 7 does not work.

left is still unfixed
#4
The gpu temps does not display. Does anyone else have the same problem? It happened from b52 to b53. The fan speed doesn't change anymore. I think this happened earlier.

ati 6970 - win7 x64 - 12.8
#5
Tested v0.09b60 with 1.6 mil hashes with Win7 x64:

v0.08
oclHashcat-plus64.exe -m 0 -a 3 -n 320 --remove -o foundMD5.txt -1 ?d?l 32_hex.txt ?1?1?1?1?1?1?1?1
Speed: 2331.2M/sec

v0.09b60
oclHashcat-plus64.exe -m 0 -a 3 -n 320 --bf-min=8 --gpu-temp-disable --remove -o foundMD5.txt -1 ?d?l 32_hex.txt ?1?1?1?1?1?1?1?1
Speed: 1265.6M/sec

Sad
Owner of: www.md5decrypter.co.uk
#6
(08-31-2012, 02:29 PM)atom Wrote: OK, here it is..

I have added support for the MOSIX/VCL aka virtual opencl cluster network.

You dont need to have MOSIX installed at all - VCL 1.15 is enough. Have Fun. BTW: I tested it successfully with 22 GPUS Smile

Here some nice benchmark: https://docs.google.com/a/plain-text.inf...hRUE#gid=0

More important is that there should be no issues left on AMD. That means 2711 and 2811, too. Double verify you remove all *.kernel files in case you overwrite the directory.

NV still has issues left.
System: Windows 7 64 bit, catalyst 12.8 HD5750, oclhashcat-plus beta 59

Everything works except the following:

-For -m 1710 sha512($pass.$salt), bruteforce of length 4 does not work.
Password tested: P0$7
Hash:Salt
Code:
7ef8ae5d7148d9cd860dbf557258f6813604b17288e61d8bf70126f8746bb9e9bb33aad7d8162932ce7cadcf3375f6cffad5a0ef6d1865e4f06de77b2eec5e42:284754643

Command line:

oclhashcat-plus64.exe -a 3 -d 1 -m 1710 -o found.txt --bf-min 4 --bf-max 4 -1 ?s?d?u?l hash.txt ?u?d?s?d

(08-31-2012, 02:29 PM)atom Wrote: I have added support for the MOSIX/VCL aka virtual opencl cluster network.

You dont need to have MOSIX installed at all - VCL 1.15 is enough. Have Fun. BTW: I tested it successfully with 22 GPUS Smile
Can anyone enlighten me on what it is. Does it means that we could join GPUs from different computers together if we install an opencl network?
#7
Quote:
Quote:You dont need to have MOSIX installed at all - VCL 1.15 is enough. Have Fun. BTW: I tested it successfully with 22 GPUS Smile
Can anyone enlighten me on what it is. Does it means that we could join GPUs from different computers together if we install an opencl network?

Yes, this enables you to join all the GPUS you have on your LAN (notice LAN, not internet) to bundle them on a single host. I have worked with the developer for a few weeks to get it working with oclHashcat-* and yesterday v1.15 which contains all this stuff was released. The libOpenCL.so virtually makes oclHashcat-* think all GPUS are local. In other words you can build totally uber computers this way. I will write more detailed about this when I find some time.
#8
(09-01-2012, 01:19 AM)blandyuk Wrote: Tested v0.09b60 with 1.6 mil hashes with Win7 x64:

v0.08
oclHashcat-plus64.exe -m 0 -a 3 -n 320 --remove -o foundMD5.txt -1 ?d?l 32_hex.txt ?1?1?1?1?1?1?1?1
Speed: 2331.2M/sec

v0.09b60
oclHashcat-plus64.exe -m 0 -a 3 -n 320 --bf-min=8 --gpu-temp-disable --remove -o foundMD5.txt -1 ?d?l 32_hex.txt ?1?1?1?1?1?1?1?1
Speed: 1265.6M/sec

Sad

I still have an eye on this, currently no Idea what the prroblem is. People say cat 12.8 is slower than 12.6. Maybe try it? Revert back to 12.6 and compare. If it does not work, come back to 12.8
#9
(08-31-2012, 11:01 PM)K9 Wrote: The gpu temps does not display. Does anyone else have the same problem? It happened from b52 to b53. The fan speed doesn't change anymore. I think this happened earlier.

ati 6970 - win7 x64 - 12.8

@matrix: Please have a look at this
#10
It's possibility to override AMD driver 8 GPU limitation. Superior thing, trying. Thanks!