Cracking sha1 with two different salts

I'm trying to crack a set of hashes which are made in the following way:

sha1( 'salt1'.pass.'salt2' )

I was trying to use -m 4900 but it seems that mode expects the two salts to be the same, which they are not.

Is there a way to do this currently, or is there a way I could patch it to work like that/add a custom mode?

Thanks in advance for any help

EDIT: I found -m 19300 on is exactly the mode im looking for, but it is marked as "in beta or not yet released". I installed 5.1.0 from github but I still get the error "Unknown hash-type '19300' selected."
This mode is available in the beta version as 19300. or
(11-27-2019, 04:40 PM)undeath Wrote: This mode is available in the beta version as 19300. or

Hi, thanks for the quick reply.

I already tried installing 5.1.0 from the git repo, but I get "Unknown hash-type '19300' selected."

hashcat (v5.1.0) starting...

OpenCL Platform #1: NVIDIA Corporation
* Device #1: ____SNIP____

Unknown hash-type '19300' selected.

hashcat (v5.1.0) starting...

you are not running a beta version
Oh.. I had 4.something from my packagemanager so I assumed 5.1 was beta. Built directly from git repo now and it works Smile Thanks for the pointers.